Technical FAQs

Ask a Question

Which devices do I need to operate Smartlink ELEC ?

You need a Smartphone (above iOS 7 or Android 4.1) with Smartlink ELEC application.
Was this helpful?
What can we do to improve the information ?