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Error when opening Vista in Engineering Client “Vista.<ComputerName> is not registered on the workstation <ApplicationServerIPAddress> in the NOM database. “

Published date: 14 May 2019

Issue

User is not able to run Vista on Engineering Client and getting an error Vista.<ComputerName> is not registered on the workstation <ApplicationServerIPAddress> in the NOM database. “ Vista runs on PME application server with no issue.

Product Line
StruxureWare Power Monitoring Expert

Environment
StruxureWare Power Monitoring Expert 8.X, Engineering Client
 
Cause
If the user defines an IP address (rather than a machine name) or the fully qualified server name rather than the short form when prompted for the primary machine during a client install, the install will complete but the following registry values will be populated incorrectly:

NetmanMachine
PrimaryMachine
 
Resolution

*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*
 
During a client install, the user is prompted to enter the name of the primary machine. If the primary machine’s IP address is entered instead of the Name. The installation may complete. However, the following error may occur when running Vista on the client machine.



This issue can be fixed by editing the client registry directly using Regedit.


 
  1. In the Registry Editor, Expand Computer.
  2. Navigate to HKEY_LOCAL_MACHINEàSoftwareàWow6432Node àSchneider Electric àPower Monitoring Expertà8.X
  3. Edit values for NetmanMachine and PrimaryMachine registries as follow;
- The NetmanMachine registry, value to the name of the primary machine to be set to the short server name. (E.g. PMESERVER1)
 
- The PrimaryMachine registry, value to the name of the primary machine. (E.g. PMESERVER1.nam.gad.schneider-electric.com)
 

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