Browse FAQs

Why doesn't my TSXCUSBMBP work after I upgraded to Windows 10 and re-installed the MBX drivers?

Published date: 16 April 2019

 Issue:
TSXCUSBMBP doesn't work after I upgraded to Windows 10 and re-installed the MBX drivers
 
Product Line:
Momentum PLC, Quantum PAC
 
Environment:
Control Expert v14
Unity Pro XL V13
 
Cause:
The drivers you have may be out of date or do not work with the 64 bit environment.
Resolution:
You will need to purchase the latest version of the MBX drivers through your local distributor.
If you have purchased the
TSXCUSBMBP within the last 12 months, you may be able to get the MBX Driver suite for free.

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.