Browse FAQs

PM8000 is not able to communicate with PME 7.2

Published date: 01 April 2019

Issue
PM8000 Series is not communicating with PME 7.2.x, but is communicating with other software applications (e.g., ION Setup, or any Modbus register reader)

Production Line
PM8000 Series

Environment
PM8000 Series Software Updates

Cause
PM8000 might be requiring further support software to be able to communicate with PME 7.2.x

Resolution
Step #1: Make sure that the PM8000 Series meter has the latest firmware version installed.
Please refer to FA244303 for more information.

Step #2: Download the .zip file in the link below to find the installer file (.exe) which will add support for PM8000 Series in PME 7.2.x

PM8000 Series Device Updater for PME 7.2.x.(ENG)​

 

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.