Technical FAQs

Ask a Question

What means into SoMachineBasic1.6 Help "The application must be configured with …. and the boot loader version 50 or later” ?

 This sentence is related to the chapter Datalogging a new feature available from version V1.6

Analysis for meaning  of  “must”
M221 has 2 system files:
 
  • a boot (%SW13 provides the version; currently 42): is downloaded only during manufacturing, not possible for a customer
  • a firmware: a new file version is provided with each new Software release, and is downloadable by any customer
The strict conditions to be able to create datalogging into the SD card is to create an application functional level 6.0 and use a PLC with firmware version V1.6.0.1 =>can be achieved with any version of the boot
Limitation when PLC boot version is lower than 50  : the PLC does not recognize a SDcard named DATA as one dedicated for datalogging operation, so it does not start in RUN during powerOn sequence if the SDcard used for datalogging is present  
 
Workarounds for customer implemting Datalogging (out of prototyping phase)
With current M221 samples, after PowerOff, take care to make remove the SDCard in order the M221 goes in RUN at the next PowerOn
OR
Use a M221 PLC manufactured from mai 2017: it will contain a boot version 52
 
Was this helpful?
What can we do to improve the information ?