Technical FAQs

Ask a Question

Task is in Use when trying to delete a tag in SMS

Issue
Can't delete a task that says it's in use but does not belong to a sheduled task

Product Line
SMS 4.0, 4.2, 4.3 

Environment
Deleting tasks in SMS

Cause
The task was likely in use when it was removed from the Scheduled Tasks or the device was taken out of service

Resolution

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.* 

1. Take the system offline
2. Shut down the System Manager Software
3. Click Start -> Run -> and type services.msc and hit ok
4. Stop the PowerLogic network Router Service
5. Open SQL Management Studio and Login
6. Right click on the SMS_System database and click Tasks and Backup. Save a backup of the database
7. Drop down the SMS_System database and then tables
8. Rick click on CS_Alarm_Tasks and hit open table
9. Delete the task in question
10. Start the Powerlogic Network Router Service
11. Open the System Manager Software and bring it back online. 


 
Was this helpful?
What can we do to improve the information ?