Technical FAQs

Ask a Question

Why with the SomachineBasic version V5.1SP1 I can’t download my old/existing application to a M221 ?

 From SoMachineBasic  version V5.1SP1 , when the application is protected by a password  ,as encryption strategy has been changed, this involve some version  compatibility rules between
-Firmware version
-Application content configurated Functional level

Case M221 Firmware version is <=1.5
If the firmware into the connected M221 is version  inferior to V1.5.1.0  then it’s not possible to download an application having  the  configurated “application protection “active with  a password
When connected to the M221 SoMachineBasic give the message “download is not allowed for application protected under functional level less than 5.1
 
But in fact ,instead to go to try to change the Functional level of the application , it’s mandatory to upgrade the M221 firmware with a V1.5.1.0 (or higger) firmware version

 
Case M221 Firmware version is already >=1.5.1.0
If Functional level of the application is less than 5.1, then it’s not possible to download an application with soMachineBasicV5.1SP1

When connected to the M221 SoMachineBasic give the message “to be able to download the application ,upgrade your application functional Level to 5.1 , delete the existing , or, otherwise disable the application protection
Then the 2 option are possible:
Set the functional level to V5.1  or set a blank password for the application protection
 
Was this helpful?
What can we do to improve the information ?