Technical FAQs

Ask a Question

Is it possible to clear the contents of the ION_SystemLog database?

Issue:
A customer would like to clear the contents of the ION_SystemLog database because it contains a large number of unwanted events.

Product Line:
Power Monitoring Expert 8.2

Environment:
ION_SystemLog database

Cause:
A large number of service or system events can cause the SystemLog database to grow in size.

Resolution:
The cause of a large number of system or service events should be identified and corrected prior to performing this procedure.

** Warning: Changes made to the PME databases can leave the system inoperable and require restoration from recent back ups or reinstallation.  The following prcedure assumes recent database back ups are available and the user is familiar with SQL Management Studio and PME. **

The Query below can be used for PME 8.2 system to purge the contents of ION_SystemLog starting with a blank database.

USE [ION_SystemLog]

TRUNCATE TABLE Diagnostic
TRUNCATE TABLE EventID
TRUNCATE TABLE EventException

-- Delete all records
DELETE FROM Event
-- Set current ID to "1"
-- If table already contains data, use "0"
DBCC CHECKIDENT (Event, RESEED, 0)
Was this helpful?
What can we do to improve the information ?