Technical FAQs

Ask a Question

Which version of LTU for Micrologic Compact NSX works with Windows XP, 7, 10?

LTU versions up to V9.2.2 supported Windows XP and Windows 7

From LTU V10.0.0, support for
Windows 7 and 10 was added. However, Windows XP is no longer supported with this version. 
 
Was this helpful?
What can we do to improve the information ?