Technical FAQs

Ask a Question

How to open an older application when Unity returns the error 'Project file not compatible'

Goals and Symptoms
How to open an older application when Unity returns the error 'Project file not compatible'

Facts and Change
Unity

Causes and Fixes
If you try to open a Unity application ('.stu') from an older version of Unity, it will return the following error message:
The reason this occurs is because a '.stu' file can only be opened using the Unity version that was used to create and
save it.




The following workaround can be used to open the '.stu' file from the older version of Unity,
  • Open a command prompt window.
  • Change the path to the location of the folder that the '.stu' file is located in.
  • Rename the '.stu' file from the older version to a '.sta' file.
e.g.

       If the filename is 'Demo.stu', rename it to 'Demo.sta'.
 
Note: If the older version application has been saved and  build was never never performed on it, the workaround will not work.
 
Was this helpful?
What can we do to improve the information ?