Technical FAQs

Ask a Question

PME 7.2.x or 8.0 Web Application gives an "HTTP 503 Service Unavailable" error message when Reports is selected

Issue
The customer is receiving an "HTTP 503. The service is unavailable" error message when selecting the 'Reports' tab through Web Applications.



Product Line
Power Monitoring Expert 7.x / 8.x

Environment
Web Reports

Cause
The 'WebReporterAppPool' Application Pool within Internet Information services is not started and crashes if started manually.

Recommended Resolution
 
This resolution does not require uninstalling Microsoft Monitoring Agent.
  • Add “Read” access permission for the WebReporterAppPool application pool account to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\System Center Operations Manager\12\APMAgent
Additional Information
  • Although SCOM 2016 Agent (Microsoft Monitoring Agent) installs the .Net Application Performance Monitoring (APM) component in the disabled state by default, it adds a registry setting to load inactive APM into IIS Application pools.
  • If APM is not yet configured for this server, those application pools will only have APM loaded in inactive state without any monitoring.
  • If the application pool account has no access to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\System Center Operations Manager\12\APMAgent registry key, inactive APM won’t be able to read that key and this application pool process may crash. This is what happens to the WebReporterAppPool application pool.

Alternate Resolution
Windows updates will install a tool named the "Microsoft Monitoring Agent".  This tool applies a policy to the application pool that causes it to crash.  Uninstalling the tool through Add/Remove programs will allow Web Reports to function as expected.
Was this helpful?
What can we do to improve the information ?