Technical FAQs

Ask a Question

PME/SPM: How to edit a dashboard created by a user that has been deleted?

Issue:
A customer is unable to edit a dashboard in SPM or PME which was created by a user that has been deleted.

Product Line:
StruxureWare Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.0

Environment:
Web Applications Dashboards

Cause:
If a dashboard is created by a user, only that user can edit the dashboard. 

Resolution:

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.* 

If the user that created the dashboard has been deleted, then you will need to manually reassign the dashboard to another user.

  1. Open SQL Server Management Studio, then open Dashboard.Dashboard table for editing within the Application Modules database
  2. Locate the field within the CreatorID column that associates the deleted user with a particular dashboard

      3. Edit this field to replace the deleted user's username with an active user's username that has an access level of Controller or greater
      4. Exit SQL Server Management Studio and then launch the SPM/PME Web Applications
      5. 
Log into the Web Applications with the user that was associated with the dashboard

You should now be able to edit the dashboard.
 

Was this helpful?
What can we do to improve the information ?