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Diagnostic Viewer Error on an Engineering Client Running in a Different Domain

Issue
A user has installed a PME Engineering Client on a different domain than the primary server. When accessing the Diagnostic Viewer the user receives an error and the diagnostic connection fails. This can be fixed by adding the username / password on the primary server that matches the username / password the user is using on the client.

The client can connect to the primary ION Server and use Management Console but receives an error when opening a site under the Communications Diagnostics tree.

An error occurred while trying to retrieve diagnostic information. Please ensure that the application is running.(Diagnostics Connection Failed)

The user can view Log Inserter diagnostics.

Product Line
ION Enterprise 5.5
ION Enterprise 6.0
Struxureware Power Monitoring 7.0.1
Power Monitoring Expert 7.2
Power Monitoring Expert 8.0

Environment
Diagnostic Viewer

Cause
The ION Enterprise Client passes the currently logged on user s Windows username and password to the primary server for authentication. The ION Primary Server does not have a local user with those credentials. The user information is not available since the primary server is outside of the domain. The authentication is failing when the diagnostics viewer is requesting the diagnostics information from siteserv via DCOM.

Resolution
Create a local user on the primary server that has the same username and password as the user running the client. This should allow the authentication process to succeed and give access to the Communication Diagnostic viewer.

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