Technical FAQs

Ask a Question

Device Support Updater for ION7550/7650 in ION Enterprise

Older versions of the ION Enterprise software either do not natively support the ION7550/ION7650 device types or do not support all features available in the latest available firmware.

Product Line
ION Enterprise V5.0 
ION Enterprise V5.5
ION Enterprise V5.6 

Device Support Update

To add support for the ION7550/ION7650 series meters to older versions of ION Enterprise, download the ION Enterprise software updater. These updater files are compatible with ION Enterprise and Pegasys. Remember that the Updater files must be applied to all machines in your ION Enterprise network, including all primary, secondary, and client machines, for the upgrades to be effective.

ION7550/ION 7650 Updater V360 (Jan 2011)


ION7550/ION7650 Updater V355 (Feb 2010)


ION7550/ION7650 Updater V310 - V330 (Feb 2007)



Was this helpful?
What can we do to improve the information ?