Technical FAQs

Ask a Question

Error message when logging into SQL Server Management Studio (SSMS) "Value cannot be null"

Goals and Symptoms

Issue
When opening SSMS on SQL Server the connection dialog will appear but after providing login credentials an error message will indicate

Value cannot be null

Clicking Ok to this error message will establish the connection, but no ION Enterprise databases or system databases will be present. Expanding any of the folders will produce the error Value cannot be null.

Product Line
SQL Server Management Studio (SSMS)

Environment
Database Engine

Cause

This can occur if the temp folders in the user accounts are deleted.



Resolution

The missing folder can be determined by using Windows Process Monitor from SysInternal Tools. Set the filter to "Process Name is ssms.exe" and "Path contains AppData\Local\Temp"

After determining the missing temp folder, manually create the folder in the C:\Users\<username>\AppData\Local\Temp\ directory

 
Was this helpful?
What can we do to improve the information ?