Technical FAQs

Ask a Question

Query execution failed for data set 'DeviceStatus' when generating report

Issue
A customer can logon WebReporter successfully and see Default report packs. However, when he tries to generate the report, the following error is displayed: -


=====================================
An error has occurred during the report processing.
Query execution failed for data set 'DeviceStatus'.
a .NET Framework error occurred during the execution of user-defined routine or aggregate "ReportView_DeviceStatus": System.Net.WebException:
The request failed with HTTP status 404: Not Found. System.Net.WebException: at
Syste.Web.Services.Protocols.SoapHttpClientProtocol.REadresponse(SoapClientMessage message, WebResponse response, Stream
reponseStream, Boolean asynccall) at System.Web.Services.Protocols(SoaphttpClientProtocol.Invoke(String methodName, Object[] parameters)
at PowerMeasurement.Reporting.View.ReportDataService.GetViewData(String reportID, String ViewName, ArgumentEnvelopeCollection arguments)
at PowerMeasurement.Reporting.View.ControllerProxy.GetViewData(String reportID, String view, ArgumentEnvelopeCollection arguments) at
PowerMeasurement.Reporting.View.Sql.ReportViewProcedures.ReportView_DeviceStatus(String reportID) .
=====================================

Product Line
ION Enterprise 5.5 
ION Enterprise 6.0

Environment
WebReporter

Cause
The IONReportDataService virtual directory is missing under the "Default Web Site". It can re-created using the attached procedure.

Resolution
Follow the procedure outlined in the attached document.
After completing the procedure detailed in the attachment, restart the IIS server as follows:
- Open a dos command prompt
- Type iisreset

After completing all of the above steps, try to generate the report again

Was this helpful?
What can we do to improve the information ?