Technical FAQs

Ask a Question

In Somachine v4.1, getting the error:"Please use CIA405.GET_STATE instead of GET_STATE (see associated warnings)" from a v3.1 project. How to resolve this issue?

Issue:
In Somachine v4.1, getting the error:"Please use CIA405.GET_STATE instead of GET_STATE (see associated warnings)" from a v3.1 project.  How to resolve this issue?

Product Line:
Somachine, CanOpen, CIA405.GET_STATE, GET_STATE

Environment:


Cause:


Resolution:
In v4.1, the libraries for the CanOpen has changed.  A work around to resolve this issue is by searching for the GET_STATE function blocks in the application and replace it with CIA405.GET_STATE instead.  It could be in a logic section or variable declaration of the POU.
Was this helpful?
What can we do to improve the information ?