Technical FAQs

Ask a Question

Can EEM 5.0 Use .Net 4.5 Instead of .Net 4.0?

According to ION EEM 5.0 System Specification Guide, .Net 4.0 is listed under required components, but .Net 4.0 is
not compatible with Windows Server 2012 and .Net 4.5 is installed on Windows Server 2012 by default.


ION EEM 5.0 Installation, Windows Server 2012

.Net 4.5 is an in-place update that replaces .Net 4.0 rather than a side-by-side installation.
The intent is for .Net 4.5 to be fully backwards compatible with applications built for .Net 4.0.


Windows Server 2012 and 2012R2 both come with .Net Framework 4.5 by default. 
.Net 4.5 is a complete replacement of .Net 4.0 and is intended to be 100% backwards-compatible.

EEM has supported Windows Server 2012 for some time and all of the testing completed validate EEM on Windows Server 2012R2 incorporated .Net 4.5.
Additionally, any 2012 or 2012R2 deployments we already completed should be running .Net 4.5.  Thus, providing a high degree of confidence that
EEM 5.0 is compatible with .Net 4.5.
Was this helpful?
What can we do to improve the information ?