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How to disable HTTP/HTTPS on an EGX100/300 Gateway

Issue
A user would like to disable the web server ports on an EGX100 or EGX300 gateway device.
 

 
Product Line
EGX100
EGX300


Environment
EGX100/EGX300  HTTP/HTTPS server configuration

Cause
A user may need to disable HTTP on TCP port 80 and port 443 respectively due to cyber-security requirements. The EGX 100 supports HTTP only while the EGX300 supports HTTP/HTTPS.

Resolution
Disabling the HTTP/HTTPS ports on the EGX100/EGX300 gateways will restrict access to the device’s webpage. You will be required to perform a ‘Master reset’ to the device in order to be able to access the webpage again.

Please contact Technical Support for information on performing a master reset on an EGX100/EGX300 gateway.

 
Disable the HTTP server on the EGX100:
 
1. Login to the EGX100 webpage by entering the EGX100 IP address into a browser address bar.
  • The default login credentials:
    • Username: Administrator 
    • Password: Gateway
2. Ensure that the EGX100 gateway device is running firmware version 3.000 or later. The firmware version can be found at the bottom left corner of the page.

3. Add ‘/adv_comms_setup.shtml’ at the end of the URL in the browser’s address bar.


4. Change the HTTP port number to 0 within the Advanced Communication Settings page.



5. Click Apply.

The EGX100 internal HTTP server is now disabled.
 
Disable the HTTP server on the EGX300:
 
1. Login to the EGX300 webpage by entering the EGX300 IP address into a browser address bar.
  • The default login credentials:
    • Username: Administrator 
    • Password: Gateway
2. Click on the ‘Setup’ menu , navigate to ‘Ethernet & TCP/IP’ and click on ‘Advanced’.


 
 
  
3.  Change the HTTP port and HTTPS port numbers to 0 within the Advanced Communication Settings page.



4. Click Apply.

The EGX300 internal HTTP and HTTPS servers are now disabled.
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