Technical FAQs

Ask a Question

Device Diagrams not working after upgrade to 7.2 from 6.0

Issue
After upgrading from ION 6.0 to PME 7.2 , When viewing diagrams in vista or the web system displays  "Cannot find default diagram"

Product Line
ION 6.0
PME 7.22

Environment 
ION Enterprise 

Power Monitoring Expert 7.2.x 


Cause 
If the  diagrams for the meters were copied  from an old ION  system  this may cause the error message "cannot find default diagram" on new PME system due to the diagrams being out of date for meter firmware.
Manual linking to the diagram works, but this may be time consuming and the diagrams are still out of date.

Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).

Resolution 1
If the diagrams were copied from the old ION system they would have overwritten the new PME diagrams.
If the diagrams installed by PME were backed up you can just copy them back over. 
If not you will need to copy the updated diagrams from a good PME installation or reinstall PME.
Before replacing the default diagrams ensure that there are no custom diagrams with the same name as they will be overwritten.

To replace the diagrams with new ones: 
Copy default diagrams to \Schneider Electric\Power Monitoring Expert\config\diagrams\ud\default , Be sure to overwrite since we are replacing the old diagrams with new ones.  You can find the default diagrams in the zipped file attached to this article.


Generate a new network diagram if necessary and open one of your meters to test. The error should now be gone , test that the data logs viewers are working as well. 


Resolution 2
Download diagrams from  this KB and replace according to instructions in resolution 1.
Was this helpful?
What can we do to improve the information ?