Technical FAQs

Ask a Question

How to edit a dashboard created by a user which no longer exists in SPM/PME

Issue:
A user is unable to edit a dashboard in SPM or PME which was created by a user that has been deleted.

Product Line:
StruxureWare Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.0

Environment:
Web Applications Dashboards

Cause:
If a dashboard is created by a user...only that user can edit the dashboard. 

Resolution:
 

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.* 

If the user that created the dashboard has been deleted, then you will need to manually reassign the dashboard to another user.

*Note: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*

Open SQL Server Management Studio then open the "Dashboard.Dashboard" table for editing within the Application Modules database.

Locate the field within the "CreatorID" column that associates the deleted user with a particular dashboard.



Edit this field to replace the deleted user's username with an active user's username that has an access level of "Controller" or greater.

Exit SQL Server Management Studio and then launch the SPM/PME Web Applications. 

Log into the Web Applications with the user that was associated with the dashboard.

You will now be able to edit the dashboard.

 

Was this helpful?
What can we do to improve the information ?