Technical FAQs

Ask a Question

"Unauthorized Access" error in ENM 8.2 or ENM 8.3

When opening "ENM Configuration" or "Monitoring and diagnostics" for ENM 8.2 or ENM 8.3, the webpage opens with an error "Unauthorized Access"

Product Line
Event Notification Module Version 8.2 or 8.3

Internet Explorer
Google Chrome

Cause 1
If its a new installation, a restart on the server has not been performed.

Cause 2
The lodged on Windows User has not been added to the 3 ENM Windows groups namely:
i) ENMAdmin
ii) ENMControl
iii) ENMUser

Cause 3
"Anonymous Authentication" is Enabled in Sites "ENMConfig" and "MonDiagSpa"

Resolution 1
If ENM has just been installed, perform a system restart on the server. If a restart is not possible, log off the current Windows user and log back in.

Resolution 2
i) Open "Computer Management" by either right clicking on My Computer and selecting Manage OR navigating to control panel-->Administrative Tools-->Computer Management.
ii) Locate Local Users and Groups under System Tools and open Groups.
iii) Open groups "ENMAdmin", "ENMControl" and "ENMUser" and add the logged in Windows user to all three groups.

Resolution 3
i) Open IIS manager by going to run and typing "inetmgr" OR navigating to control panel-->Administrative Tools-->Internet Information Services Manager.
ii) From the left side of the pane, open Sites and locate websites named "ENMConfig" and "MonDiagSpa".
iii) Under each of these websites, open "Authentication" from within IIS
iv) If "Anonymous Authentication" is enabled, disable it from the Actions tab on the right.

Was this helpful?
What can we do to improve the information ?