Technical FAQs

Ask a Question

SPM / PME - Installer gives Insufficient SQL Server Version Selected error.

Issue
When installing SPM / PME, the installer fails at Check SQL Version install with error ""Insufficient SQL Server version selected."

Product Line
Struxureware Power Monitoring  7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 7.2.x Data Center Edition/Health Care Edition

Environment
Software installation

Cause
The SQL Server version does not match what the installer checks for. 

Expected SQL Server editions:
SQL Server 2008 R2 Express SP2
SQL Server 2008 R2 Standard/Enterprise SP2/SP3
SQL Server 2012 R2 Standard/Enterprise

Resolution

Note: These procedures should not be used to force an installation on an unsupported SQL version. Doing so will result in an unsupported system configuration. 
Backup the EverythingElseBroker.xml prior to doing any editing. Improper modifications may result in an unsuccessful installation. 

Option 1
1. Copy the installation medium, say installer DVD on the local hard disk.
2. Open the EverythingElsebroker.xml for editing from the location ...\Setup\BrokerFragments
3. In the EverythingElseBroker.xml find the below:

10.0.1600.0
NOTE: Depending on version of SQL(32bit vs 64bit) being used, the below changes would have to be made in the appropriate location.
4. Open SQL Server Management Studio, find the version by right-clicking the server name in the object explorer and clicking properties. Alternatively, you can also run the below query:

SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY('productlevel'), SERVERPROPERTY('edition')

5. Append the version number after the above version number in the last line of the xml string with an OR (|) sign.
6. Restart the installer.

Option 2
1. Copy the installation medium, say installer DVD on the local hard disk.
2. Open the EverythingElsebroker.xml for editing from the location ...\Setup\BrokerFragments
3. In the EverythingElseBroker.xml find the below:
 
#10.0.1600.0 

4. Comment out the section above using a hashtag "#" at the beginning of the code.
5. Restart the installer.
Was this helpful?
What can we do to improve the information ?