Technical FAQs

Ask a Question

What is the minimum version of the softmotion libraries for MotionPro that will allow a LMC20 to work with a Lexium32 via CANmotion fieldbus?

Title
Minimum version of the softmotion libraries for MotionPro that will allow a LMC20 to work with a Lexium32 via CANmotion fieldbus
 
Issue
When a customer that has a LMC20 controller connected via CANmotion to a Lexium05 servo drive, uses softmotion libraries older then v1949 and upgrades the servo drive to a Lexium32, the system will stop working.
 
Product Line
LMC20, Lexium32, Lexium05
 
Environment
MotionPro
 
Cause
Softmotion libraries older then v1949 are not compatible with Lexium32
 
Resolution
The minimum version of the softmotion libraries for MotionPro that will allow a LMC20 to work with a Lexium32 via CANmotion fieldbus is version v1949. If the softmotion libraries are older, the system will not work. In this case update the softmotion libraries and download the project to the LMC20 controller.
Was this helpful?
What can we do to improve the information ?