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Advanced Reports archive job failing to archive data from the database

Goals and Symptoms

Issue
The DBMaintenance job which archives Advanced Report's data is failing and the archives are not being created.

The following error message can be seen in the Windows PowerLogic Event Log:

Message:PerformArchiv_Failed: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Type:PowerLogic.PMOApplicationException

Causes and Fixes

Cause

Advanced Report’s archive job has a default timeout of 30 minutes. If the archive job does not complete in it the time allotted the archive job will quit and the data will not be archived.


Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. 


The Advanced Reports archive query timeout can be adjusted in the registry at:

HKEY_LOCAL_MACHINE\SOFTWARE\Square D Company\Advanced Reports\Report Database\Archive

Change the DWORD QueryTimeoutSecs from its default value of 1800 (30 minutes) to 14400 (4 hours).

The new timeout value will give the archive job ample time to complete and remove data beyond the retention period from the SMS_AR_Report database.

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