Technical FAQs

Ask a Question

What is the minimum firmware needed for a PM710 or PM750 to upgrade to the latest firmware?

The PM700 or PM7 series meters must be at firmware 3.040 or greater in order to upgrade to the latest firmware


Legacy KB System (APS) Data: RESL210389 V1.0, Originally authored by MaTh on 01/22/2013, Last Edited by MaTh on 01/22/2013
Related ranges: PM700 series
Was this helpful?
What can we do to improve the information ?