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Communication loss in the System Manager Software (error 513) for device(s) downstream of a CM4 with an ECC21 card

Goals and Symptoms

Issue
Communications will drop out for devices on the serial port of an ECC card housed in a CM3/4 and come back on the next health check, data upload, or with a communication test (i.e. there is no loss of data). The error with the communication loss is 513 which is defined as"negative acknowledgement"

Causes and Fixes

Cause

This is is generally a wiring issue where someone will have to "ring out" or check the wiring on the daisy chain for continuity; however the problem may be solved by cycling power to the ECC21. An easy way to cycle power to the ECC21 is to do a soft reset to the meter.

Resolution

Perform a soft rest on the meter by enabling an unused data log on the CM3/4. Whenever a change is made to a data log the CM4 reset itself which, in turn, reboots the ECC card. After the initial soft reset, the unused data log can be un-enabled to return the data log to its original state (this will cause another soft reset).

Alternately, a soft reset can be initiated by writing 1110 to register 8000.

NOTE: Since making any changes to a data log clears the data in all of the logs for that meter; do an "execute now" on any tasks that get data from the data logs in the meter before making the changes to the unused data log.


Legacy KB System (APS) Data: RESL210238 V1.0, Originally authored by MaTh on 01/07/2013, Last Edited by MaTh on 01/07/2013
Related ranges: ECC21
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