Technical FAQs

Ask a Question

Which version of Power Monitoring Expert is compatible with the EM3500 meters?

The EM3500 series drivers were not supported before StruxureWare Power Monitoring 7.0.1

Product Line
EM3500, SPM7.0.1, PME7.2, PME8.0

Device Drivers

For all versions of SMS and ION Enterprise, the EM35000 device is not supported. The EM3500 device support begins in SPM7.0.1 with a device specific installer. For all versions of SPM and PME after, the EM3500 has built in support which does not require an device specific installer. 

The SPM7.0.1 EM3500 driver can be found by clicking here.

Was this helpful?
What can we do to improve the information ?