Technical FAQs

Ask a Question

SPM 7.0 - Error while installing Report Packs from previous versions

Goals and Symptoms

Symptoms
You are trying to install a report pack from another system on a fresh SPM 7.0 install. When validating, it gives you the following error and you cannot install:


=======================================================================

Default Reports 6.0                         Not Installed

---------------------------------------------------

Validation error.  The report pack ‘MyCustomReportPack’ is corrupt or was created for a previous version of SPM.  Check the system log for more information.  Please contact your report pack provider.

======================================================


Keywords

StruxureWare Power Monitoring 7.0 Reports Cannot Install Upload Report pack Reportpack
Validation error. The report pack is corrupt or was created for a previous version of SPM. Check the system log for more information. Please contact your report pack provider.

Causes and Fixes

Cause

The format of report packs has changed between ION-E 6.0 and SPM 7.0. Custom report packs created for use with 6.0 have to be upgraded to the new format before they can be used in 7.0.


Resolution

Update your report pack to be compatible with SPM 7.0 with the following tool:

ReportPackUpgradingTool.zip

Make sure you read the User Guide before proceeding. Both the .exe and the .dll files need to be unzipped to the same location before running.

Document Change History

Date and Initials Comments
2012-05-14 DRM * Re-published article to "Controlled" access level.
2012-May-22 * Altered distribution level to public.

Last Revised: April 12, 2012
Public
All content © 1992-2012 Schneider Electric

Was this helpful?
What can we do to improve the information ?