Technical FAQs

Ask a Question

Reporter on an client installation will not query the ION_Data database. Reporter gives the error "SQL Server does not exist or access denied" or "Specified SQL server not found".

Issue
User is unable to run Repgen reports from a client machine

Reporter gives one of the following errors:
*ERROR* Error -2147467259 [[DBNETLIB]]ConnectionOpen (SQL Server does not exist or access denied.) has occured in Microsoft OLE DB Provider for SQL Server

*ERROR* Error -2147467259 [[DBNETLIB]]ConnectionOpen (Connect()).[Specified SQL server not found.) has occured in Microsoft OLE DB Provider for SQL Server

Product Line
ION Enterprise 6.0
StruxureWare Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x, 8.x

Environment
Management Console, Vista and Designer work after adding the port to the database connections in the registry, however previously created reports will not run. The database connections are now \ION,1433 instead of \ION. Creating a new report works. Adding ,1433 to the database connection in Reporter does not work. Connecting to the database and querying with excel allows a valid connection if ,1433 is added to the SQL instance name. The same report works on the server and could possibly work on other client machines.

Resolution

*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop). *

1) On the Server machine go to the report folder ...[software install folder]\config\reports
2) Open the report that won't run on the client in Excell.
3) Go to format > sheet > unhide and choose |PRIVATE|Datasheets
4) Change column Y from \ION to \ION,1433
5) Go to format > sheet > hide and then save the excel sheet.

The report should now work on the client computer.

Was this helpful?
What can we do to improve the information ?