Technical FAQs

Ask a Question

What is the minimum firmware version required on a Series 3000/4000 Circuit Monitor that enables it to access the features available in the ECC21 firmware version 5.0?

Product Line
Series 3000 Circuit Monitor
Series 4000 Circuit Monitor
ECC21

Resolution
The Series 3000/4000 Circuit Monitor must have firmware version 12.81 or greater in order to enable it to access the features of the ECC21 firmware version 5.0.

Was this helpful?
What can we do to improve the information ?