Technical FAQs

Ask a Question

What is the minimum firmware requirements for Powerlogic meters in StruxureWare Power Monitoring Expert?

Issue
What is the minimum firmware requirements for Powerlogic meters in StruxureWare Power Monitoring Expert?

Product Line
Powerlogic meters
StruxureWare Power Monitoring Expert 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.0

Environment 
Power Monitoring Expert Software Configuration

Resolution
It is strongly recommended to upgrade the firmware to the recommended levels to rule out any potential issues. Below are minimum firmware requirements that SPM/PME will support.

Device Type Firmware Version(s)
PM810/PM820/PM850 10.6
PM870 10.7
CM3xxx 14.35
CM4xxx 14.34
PM750 3.02
PM700/PM700P/PM720 3.01
MicroLogic H 8.261 (Logic2005AF)
MicroLogic P 8.261 (Logic2005AF)
MicroLogic A No change in the last five years
MicroLogic Communications Module Use in type A, P, and H = 2.001
CM2050/CM2150/CM2250/CM2452 17.xxx
CM2350/CM2450 16.xxx
PM600 12.004
PM620 12.002
PM650 22.7
Momentum PLC D16 (EPSS) 1.01
Momentum PLC A8 (WAGES) 3.03
Momentum PLC D10 (WAGES) 3.03


NOTE: SPM can still support older firmware versions. However, some registers might be supported on those versions; and thus they may cause “n/a” or nonexistent measurement displays.
CM2 OS firmware version 14 (and older) has a Y2K issue that affects correct operation in the software. You should upgrade to the latest version.
Vista diagrams may not open correctly if older firmware versions are used. Contact Technical Support for assistance.

Was this helpful?
What can we do to improve the information ?