Technical FAQs

Ask a Question

Is the TSXCUSBMBP Modbus Plus adapter compatible with USB version 2.0 or 3.0?

Goals and Symptoms

Is the TSXCUSBMBP Modbus Plus adapter compatible with USB version 2.0 or 3.0?

Causes and Fixes

Yes.. The TSXCUSBMBP Modbus Plus Adapter supports USB Versions 1.1 or greater....


Legacy KB System (APS) Data: RESL212786 V1.0, Originally authored by MiMe on 10/17/2013, Last Edited by MiMe on 10/17/2013
Related ranges: Modbus Plus
Was this helpful?
What can we do to improve the information ?