Technical FAQs

Ask a Question

STBNIP2311 Advantys Ethernet Dual Port NIM Firmware Upgrade - Exec v.4.00

Release Notice

The purpose of this resolution is to inform STBNIP2311 users that the Exec and Web pages have been upgraded to the following:

    • Exec v.4.00
    • Kernel v.2.04 (was not changed)
    • Web v.3.00

Goals and Symptoms

STBNIP2311 Exec version 4.00 only needs to be installed if the STBAHI8321 module will be used on an Advantys STB Island. Version 4.00 is the minimum version required to support the HART module STBAHI8321. The STBNIP2311 is the only STB NIM that supports the STBAHI8321 HART module.
The scope of the HART multiplexer solution is comprised of a Modicon STB Ethernet module (STBNIP2311), one or more HART modem modules (STBAHI8321). Optionally Modicon STB analog IO modules and loop power supplies can be used to enhance the functionality of the solution.

Facts and Changes

Requirements for HART functionality.

  • Software:
      • Advantys Configuration Software version 5.5 or higher
      • Advantys Configuration Software Patch version 5.5.0.4_B6 required for ACS v5.5 only
    Firmware:
      • STBNIP2311 version 4.00 or higher
    Hardware:
      • STBAHI8321 (HART module)

    Reference Documentation:
      • HART STB Multiplexer Applications Guide
      • Advantys STB Special Modules Reference Guide
      • Advantys STB Standard Dual Port Ethernet Modbus TCP/IP Network Interface Module Applications Guide
      • STBAHI8321 HART Interface Module READ ME

Causes and Fixes

The new Exec., Kernel, and web versions are field upgradable for the STBNIP2311 Ethernet NIM hardware. This Exec is exclusively for the STBNIP2311 and cannot be used in STBNIP2212's Ethernet NIMs.

Exec file, nip2311_upgrade_[fw]_v4.00.10_[web]_v3.00.00.exe, will launch the loader utility program and prompt the user to enter the IP address of the Ethenet NIM. The Exec, Kernel, and web files will load sequentially and then reboot the NIM when it finishes loading.



The self-extracting executable file allows the user to enter up to 5 different IP addresses for updating. To upgrade more than 1 at a time, simply enter additional IP addresses separated by a space when prompted to during the upgrade.
Was this helpful?
What can we do to improve the information ?