Technical FAQs

Ask a Question

Web Designer project cannot be downloaded due to a mismatch in the exec firmware version

Goals and Symptoms

Web Designer project cannot be downloaded due to a mismatch in the exec firmware version

Facts and Changes

All Factorycast, Factorycast HMI and Factorycast Gateway mdoules

Causes and Fixes

If the project cannot be downloaded due to a mismatch between the older exec firmware version that is in the module and the newer version in the Web Designer project, the user can perform a target update (click on 'Target\Upgrade Target Version'). During a target update, the software scans the hardware for differencesand modifies the respective exec fimware files in the project to match what is in the module.
If the project cannot be downloaded due to a mismatch between the newer exec firmware version that is in the module and the older version in the Web Designer project, the user can perform a target update provided, that the appropriate support files for the exec firmware are installed in Web Designer. If the exec firmware files are not installed, the 'Target\Upgrade Target Version' selection will only upgrade to the latest version that is installed in Web Designer. If the upgrade version number for 'Target\Upgrade Target Version' does not match the exec firmware version in the module, the updated Web Designer software must be installed.

Was this helpful?
What can we do to improve the information ?