Technical FAQs

Ask a Question

'Windows Installer version 2.0 is required' error gets returned when trying to install the Advantys Configuration Software

Goals and Symptoms

'Windows Installer version 2.0 is required' error gets returned when trying to install the Advantys
Configuration Software.

Facts and Changes

All versions of Advantys Configuration Software.

Causes and Fixes

'Windows Installer version 2.0 is required' error gets returned when trying to install the Advantys
Configuration Software. When you click on the OK button to close the error window, the following
error is also returned.


The problem could occur in 'Windows XP' due to the following:

  • The Windows registry settings for 'Advantys' somehow got corrupted during the installation.
  • The Windows registry settings for 'Advantys' did not get written because the user did not
have full administrative rights.
  • Windows Installer version 3.1 or later is not installed.

Note: 'Windows Installer version 2.0' is included on the installation CD but, it only works with
'Windows 2000', 'Windows 98/ME', 'Windows NT4' or 'Windows 95'. 'Windows XP'
requires version 3.1 or later.


If the 'Windows Installer' is at version 3.1 or later and the user is logged on as an administrator:
  • Uninstall the 'Advantys Configuration Software'.
  • Clean the registry (Reference resolution titled 'How To Completely remove 'Advantys
Configuration Software. from the PC').
  • Reboot the PC.
  • Log into the PC as an administrator.
  • Install the 'Advantys Configuration Software'.


If the user did not have full administrative rights.
  • Uninstall the 'Advantys Configuration Software'.
  • Clean the registry (Reference resolution titled 'How To Completely remove 'Advantys
Configuration Software. from the PC').
  • Reboot the PC.
  • Log into the PC as an administrator.
  • Install the 'Advantys Configuration Software'.


If the 'Windows Installer' is not at version 3.1 or later:
  • Uninstall the 'Advantys Configuration Software'.
  • Clean the registry (Reference resolution titled 'How To Completely remove 'Advantys
Configuration Software. from the PC').
To verify the 'Windows Installer' version:
  • Open the 'C:\Windows\system32' folder.
  • Move the mouse cursor over the file named 'msi.dll' until the properties windows appears.



If all of the above solutions have been tried and the error still gets returned,
  • Open the CD.
  • Right click on the file named 'Start'.

  • Select 'Properties.
  • Click on 'Compatibility'.
  • Click on 'Run this program in compatibility mode for:
  • Select the one of the options (i.e., 'Windows 98 /Windows Me').
  • Click on the 'Apply' button.
  • Click on 'OK'.

  • Install the 'Advantys Configuration Software'.




Was this helpful?
What can we do to improve the information ?