Technical FAQs

Ask a Question

Can the 6000-021 Cybercalc software be run on Pentium based PCs?

The 6000-021 Cybercalc software is not qualified for usage on Pentium based PCs, however it has been used previously with success. You may need to run SLODOS, CPUKILLER, or other freeware to slow the PC down.

Was this helpful?
What can we do to improve the information ?